By: Thomas Kuechenthal user 04 Aug 2019 at 3:39 p.m. CDT

3 Responses
Thomas Kuechenthal gravatar
Hi! I want to install gluu-casa in addition to my running gluu-server-3.1.6.sp1 on my Debain 9 server. But the "apt install gluu-casa" command shows the following output: ``` #apt install gluu-casa Reading package lists... Done Building dependency tree Reading state information... Done The following additional packages will be installed: gluu-server-3.1.6 The following NEW packages will be installed: gluu-casa gluu-server-3.1.6 0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded. ``` As you can see the process is going to install the gluu-server again. I think there is an issue with the Debian dependency tree. gluus-casa has the "gluu-server-3.1.6" as a dependency and not "gluu-server-3.1.6.sp1". I'm not able to install gluu-casa with the most current version of the gluu-server. Thanks, Thomas

By William Lowe staff 07 Aug 2019 at 10:32 a.m. CDT

William Lowe gravatar
So, seems like it was an issue with the sp dependency. We are issuing a new package to align. Thanks for the note. Stay tuned for an updated package.

By Davit Nikoghosyan staff 07 Aug 2019 at 10:59 a.m. CDT

Davit Nikoghosyan gravatar
Hi Thomas, We released new gluu-casa packages (Version: 3.1.6.sp1). This new version depends on gluu-server-3.1.6.sp1 Please use this new version. Thanks, Davit

By Thomas Kuechenthal user 07 Aug 2019 at 2:18 p.m. CDT

Thomas Kuechenthal gravatar
Hi Davit, thanks for the update! - WIll there be a patch script for existing installations? - And by the way, you might want to update the docs here: https://gluu.org/docs/casa/installation/installation/#debian-9-stretch The "stretch" section shows the "jessie" commands. That could lead to some confusion for unexperienced users :) Thanks, Thomas