By: Kee Wee Wong named 19 Oct 2021 at 12:57 a.m. CDT

9 Responses
Kee Wee Wong gravatar
Hi Support, We are currently running 4.2.2 SP1 in an air gapped network with no internet access and we would like to upgrade the Gluu Server to the latest 4.2 version, which is 4.2.3 The upgrade guide in the documentation is only for Internet connected system. https://www.gluu.org/docs/gluu-server/4.2/upgrade/ Is there a guide or script for offline upgrade to version 4.2.3? Thank you!

By Mohib Zico staff 19 Oct 2021 at 1:43 a.m. CDT

Mohib Zico gravatar
Hello Kee Wee, Is this for [same](https://support.gluu.org/upgrade/8714/offline-upgrade-from-gluu-server-40-to-42/) customer?

By Kee Wee Wong named 19 Oct 2021 at 2:07 a.m. CDT

Kee Wee Wong gravatar
Hi Mohib, Yes, this is for another site which we have installed 4.2.2

By Mohib Zico staff 19 Oct 2021 at 2:19 a.m. CDT

Mohib Zico gravatar
Thanks. We don't need upgrade script for that as they are in same branch ( 4.2.x ). You can grab war file from `https://ox.gluu.org/` and replace war file. As for example: - oxTrust: https://ox.gluu.org/maven/org/gluu/oxtrust-server/ - oxAuth: https://ox.gluu.org/maven/org/gluu/oxauth-server/ - Shibboleth: https://ox.gluu.org/maven/org/gluu/oxshibbolethIdp/

By Kee Wee Wong named 19 Oct 2021 at 2:35 a.m. CDT

Kee Wee Wong gravatar
Hi Mohib, We are actually looking at this issue https://support.gluu.org/outages/9205/unexplained-outofmemoryerror-periodically-invalidates-ldap-environment/ This seems to be the cause of our oxtrust/oxauth issue where the LDAP cannot be contacted and both oxtrust and oxauth encountered 5xx error. Based on the ticket, 4.2.3 should resolve the issue. I don't think just upgrading the war files will fix the issue?

By Kee Wee Wong named 20 Oct 2021 at 1:37 a.m. CDT

Kee Wee Wong gravatar
Hi Mohib, From the issue I mentioned https://support.gluu.org/outages/9205/unexplained-outofmemoryerror-periodically-invalidates-ldap-environment/ We see that there are actually no changes in the OpenDJ version from 4.2.2 to 4.2.3, so we can just upgrade the war files and see if it resolves our memory leak issue?

By Mohib Zico staff 20 Oct 2021 at 1:20 p.m. CDT

Mohib Zico gravatar
Hmmm... In 4.2.3 Final, I faced issue with OpenDJ, so had to manually [patched](https://gist.github.com/mzico/76fd1044d663eb09f03f83efe3f17f61) OpenDJ there. I believe, recent 4.2.3 sp2 / sp3 ( whichever is the last version of 4.2.3 series ) has that fix.

By Mohib Zico staff 31 Oct 2021 at 9:18 p.m. CDT

Mohib Zico gravatar
Hello Kee Wee, Just touching base to know how things are going there. Thanks!

By Kee Wee Wong named 08 Nov 2021 at 10:17 p.m. CST

Kee Wee Wong gravatar
Hi Mohib, Sorry for the lack of updates. We have updated the UAT environment without any issue and we currently scheduling the upgrade this Sunday morning. We'll keep you in the loop if we encounter any issue. Thank you!

By Mohib Zico staff 14 Nov 2021 at 9:06 p.m. CST

Mohib Zico gravatar
Hi Kee Wee, Thanks much!