By: Mark Diender Account Admin 22 Jun 2017 at 2:56 a.m. CDT

4 Responses
Mark Diender gravatar
I'm trying to upgrade my 2.4.4 installation to 3.0.2 (and i had the same issue with 3.0.1) but i'm getting stuck with the SAML Module. The entire upgrade process runs without error, but after everything is booted up, i'm missing the SAML configuration in the menu. Also SAML isn't working for servers that used to work. If i run a clean install the SAML module does show up. I followed https://gluu.org/docs/ce/3.0.2/upgrade/ to the letter. i'm not sure how to proceed. Here are some (semi-anonymized) logs which i think are relevant, passwords, hashes and identifiers are removed/edited: setup_error.log: https://pastebin.com/4Yd4U56F setup.log: https://pastebin.com/ZHQyFRuR setup.properties: https://pastebin.com/TNuYKN1n I can't find any logging which could lead me to the problem. is this issue known?

By Arunmozhi P staff 23 Jun 2017 at 1:54 p.m. CDT

Arunmozhi P gravatar
Hi, Thanks for the detailed report. Yes. This is a known issue, because of the configuration changes in that happened due to migration from Shibboleth v2 to v3. We are working towards a fix. I will update once we have a fix.

By Mark Diender Account Admin 26 Jun 2017 at 5:10 a.m. CDT

Mark Diender gravatar
Hi Arunmozhi, Thank you for your reply. Do you have any indication towards a release date for the fix? Our environment isn't huge so a clean install might be the way to go. But if the fix is coming this week or next, i'd rather wait it out.

By Arunmozhi P staff 27 Jun 2017 at 8:03 a.m. CDT

Arunmozhi P gravatar
Hi Mark, I would suggest that you wait until this weekend. And if can't release a fix until then, you can perhaps go for a clean install.

By Arunmozhi P staff 03 Jul 2017 at 1:02 p.m. CDT

Arunmozhi P gravatar
Hello Mark, I have good news. We finally found the bug and fixed it. We have also updated the export and import script to consider for the bug. Migration of SAML works as expected. Good luck migrating your 2.4.4 instance to the latest 3.0.2 version. Regards, Arun P.S: I am closing this ticket. Kindly reopen it in case the migration fails.